Nem datoliste

19.05.2014 Revideret 07.10.2020
 

I alle regneark kan du hurtigt oprette en datoliste.

Dette tips kan du bruge i MS Excel, LibreOffice Calc og Google Docs.


Hvis du benytter Excels indbyggede lister til datoer og dage bliver alt sat ind som tekst. Det betyder at du skal skifte hele listen hvis du f.eks. skal skifte til et nyt år.

Hvis du gerne vil nøjes med at ændre i 1 celle skal du oprette fleksible lister.

Du kan oprette en fleksibel liste over datoer ved at:

  1. Åbne et regneark
  2. I celle A1 skriver du 1. dato
  3. I A2 skriver du: =A1+1
  4. Brug Fyldhåndtaget til at trække indholdet af A2 ud indtil listen er færdig
Datoliste i Excel

Næste gang du skal bruge en liste åbner du regnearket og indtaster den nye dato i 1. celle (A1). De øvrige celler retter sig selv til.

Fyldhåndtaget finder du i nederste højre hjørne af cellen. Se evt. vejledning på Microsofts hjemmeside.

Skriv også dagens navn

Hvis du gerne vil have skrevet den tilhørende ugedag har Excel en funktion der kan hjælpe.

Funktionen UGEDAG leverer et tal for den dag som datoen repræsenterer. Vil du skrive det med dagens navn skal du selv "oversætte det". Til det kan du bruge en (mange) HVIS-funktion(er).

F.eks.

=HVIS(UGEDAG(A5;1) = 1;"søndag";HVIS(UGEDAG(A5;1) = 2;"mandag";HVIS(UGEDAG(A5;1) = 3;"tirsdag";HVIS(UGEDAG(A5;1)=4;"onsdag";HVIS(UGEDAG(A5;1)=5;"torsdag";HVIS(UGEDAG(A5;1)=6;"fredag";HVIS(UGEDAG(A5;1)=7;"lørdag";"Ugedag kan ikke detekteres")))))))

Ugenummer

Excel har også en formel der viser ugens nummer.

Hvis datoen står i celle A5 så skriv

=UGE.NR(A5;21)

21 står for at ugen skal starte på en mandag dvs. det europæiske ugenummereringssystem.

Et helt år i et regneark

Skal du bruge alle dage i et år kan du

  1. gruppere 12 ark
  2. Udføre pk. 1 - 4 ovenfor (for at oprette en månedsliste)
  3. Ophæve grupperingen
  4. Rette datoen i celle A1 på de 11 bagerste ark

A1 på de 11 bagerste rækker skal enten være den 1. i måneden eller en henvisning til den sidste dag i forrige måned + 1. (F.eks. kan der i Juni!A1 stå =Maj!A34+1)

Liste med datoer, ugedage og ugenummer

Liste med dato, ugedage og ugenr. (til højre)

Månedsliste

Skal du bruge en liste over månederne (f.eks. den 1. i hver måned) er du nød til at skrive i alle cellerne - du kan ikke bruge fyldhåndtaget. Det skyldes at månederne har forskelligt antal dage.

Skriv f.eks.

  • 1. dato i A1
  • A1+antallet af dage i 1. måned i celle A2
  • A2+antallet af dage i 2. måned i celle A3

osv.